Unanswered Questions

This page lists MaplePrimes questions that have not yet received an answer

The documentation for the option AllSolutions for int says that the results are always valid for all real parameter values (in the endpoints). That seems like a pretty major claim. Each of these three is already wrong for a=-1/2, b=1/2:

int(1/ln(t), t = a .. b, AllSolutions);
    piecewise(ln(a) < ln(b), piecewise(And(1 < b, a < 1), undefined, piecewise(a = 1, infinity,
    Ei(1, -ln(a)))+piecewise(b = 1, -infinity, -Ei(1, -ln(b)))), ln(b) = ln(a), 0, ln(b) < ln(a),
    -piecewise(And(1 < a, b < 1), undefined, piecewise(b = 1, infinity, Ei(1, -ln(b)))+
    piecewise(a = 1, -infinity, -Ei(1, -ln(a)))))

int(sqrt(t^2-1+I*t), t = a .. b, AllSolutions);
    piecewise(a < b, (1/2)*sqrt(b^2-1+I*b)*b+I*sqrt(b^2-1+I*b)*(1/4)-3*ln(-2*signum(0, -b, 1)^2*
    b^2+2*sqrt(b^4-b^2+1)*signum(0, -b, 1)^2+4*b*sqrt(2*sqrt(b^4-b^2+1)+2*b^2-2)+2*
    signum(0, -b, 1)^2-2*signum(0, -b, 1)*sqrt(2*sqrt(b^4-b^2+1)-2*b^2+2)+6*b^2+2*
    sqrt(b^4-b^2+1)-1)*(1/16)-3*ln((-I*(signum(0, -b, 1)*sqrt(2*sqrt(b^4-b^2+1)-2*b^2+2)-1+I*
    sqrt(2*sqrt(b^4-b^2+1)+2*b^2-2)+(2*I)*b))*(1/sqrt(-2*signum(0, -b, 1)^2*b^2+2*sqrt(b^4-b^2+1)*
    signum(0, -b, 1)^2+4*b*sqrt(2*sqrt(b^4-b^2+1)+2*b^2-2)+2*signum(0, -b, 1)^2-2*signum(0, -b, 1)*
    sqrt(2*sqrt(b^4-b^2+1)-2*b^2+2)+6*b^2+2*sqrt(b^4-b^2+1)-1)))*(1/8)-(1/2)*sqrt(a^2-1+I*a)*a-I*
    sqrt(a^2-1+I*a)*(1/4)+3*ln(-2*signum(0, -a, -1)^2*a^2+2*sqrt(a^4-a^2+1)*signum(0, -a, -1)^2+
    4*a*sqrt(2*sqrt(a^4-a^2+1)+2*a^2-2)+2*signum(0, -a, -1)^2-2*signum(0, -a, -1)*sqrt(2*
    sqrt(a^4-a^2+1)-2*a^2+2)+6*a^2+2*sqrt(a^4-a^2+1)-1)*(1/16)+3*ln((-I*(signum(0, -a, -1)*sqrt(2*
    sqrt(a^4-a^2+1)-2*a^2+2)+I*sqrt(2*sqrt(a^4-a^2+1)+2*a^2-2)-1+(2*I)*a))*(1/sqrt(-2*
    signum(0, -a, -1)^2*a^2+2*sqrt(a^4-a^2+1)*signum(0, -a, -1)^2+4*a*sqrt(2*sqrt(a^4-a^2+1)+2*
    a^2-2)+2*signum(0, -a, -1)^2-2*signum(0, -a, -1)*sqrt(2*sqrt(a^4-a^2+1)-2*a^2+2)+6*a^2+2*
    sqrt(a^4-a^2+1)-1)))*(1/8), b = a, 0, b < a, -(1/2)*sqrt(a^2-1+I*a)*a-I*sqrt(a^2-1+I*a)*(1/4)+
    3*ln(-2*signum(0, -a, 1)^2*a^2+2*signum(0, -a, 1)^2*sqrt(a^4-a^2+1)+4*a*sqrt(2*sqrt(a^4-a^2+1)+
    2*a^2-2)+2*signum(0, -a, 1)^2-2*signum(0, -a, 1)*sqrt(2*sqrt(a^4-a^2+1)-2*a^2+2)+6*a^2+
    2*sqrt(a^4-a^2+1)-1)*(1/16)+3*ln((-I*(signum(0, -a, 1)*sqrt(2*sqrt(a^4-a^2+1)-2*a^2+2)+
    I*sqrt(2*sqrt(a^4-a^2+1)+2*a^2-2)-1+(2*I)*a))*(1/sqrt(-2*signum(0, -a, 1)^2*a^2+
    2*signum(0, -a, 1)^2*sqrt(a^4-a^2+1)+4*a*sqrt(2*sqrt(a^4-a^2+1)+2*a^2-2)+2*signum(0, -a, 1)^2-
    2*signum(0, -a, 1)*sqrt(2*sqrt(a^4-a^2+1)-2*a^2+2)+6*a^2+2*sqrt(a^4-a^2+1)-1)))*(1/8)+(1/2)*
    sqrt(b^2-1+I*b)*b+I*sqrt(b^2-1+I*b)*(1/4)-3*ln(-2*signum(0, -b, -1)^2*b^2+2*sqrt(b^4-b^2+1)*
    signum(0, -b, -1)^2+4*b*sqrt(2*sqrt(b^4-b^2+1)+2*b^2-2)+2*signum(0, -b, -1)^2-
    2*signum(0, -b, -1)*sqrt(2*sqrt(b^4-b^2+1)-2*b^2+2)+6*b^2+2*sqrt(b^4-b^2+1)-1)*(1/16)-
    3*ln(-(I*signum(0, -b, -1)*sqrt(2*sqrt(b^4-b^2+1)-2*b^2+2)-I-sqrt(2*sqrt(b^4-b^2+1)+2*b^2-2)-
    2*b)/sqrt(-2*signum(0, -b, -1)^2*b^2+2*sqrt(b^4-b^2+1)*signum(0, -b, -1)^2+4*b*sqrt(2*
    sqrt(b^4-b^2+1)+2*b^2-2)+2*signum(0, -b, -1)^2-2*signum(0, -b, -1)*sqrt(2*sqrt(b^4-b^2+1)-
    2*b^2+2)+6*b^2+2*sqrt(b^4-b^2+1)-1))*(1/8))

int(arctan(t+2*I), t = a .. b, AllSolutions);
   piecewise(a < b, piecewise(a < 0, I*arctan(4*a/(a^2-3))*(1/2)+(1/4)*ln(a^2+1)+(1/4)*ln(a^2+9)-
   (2*I)*arctan(2*I+a)-arctan(2*I+a)*a+I*Pi*(1/2), a = 0, -I*Pi+3*ln(3)*(1/2), 0 < a, I*arctan(4*a/
   (a^2-3))*(1/2)+(1/4)*ln(a^2+1)+(1/4)*ln(a^2+9)-(2*I)*arctan(2*I+a)-arctan(2*I+a)*a-I*Pi*(1/2))+
   piecewise(b < 0, -I*arctan(4*b/(b^2-3))*(1/2)-(1/4)*ln(b^2+1)-(1/4)*ln(b^2+9)+(2*I)*
   arctan(2*I+b)+arctan(2*I+b)*b-I*Pi*(1/2), b = 0, -I*Pi-3*ln(3)*(1/2), 0 < b, -I*arctan(4*b/
   (b^2-3))*(1/2)-(1/4)*ln(b^2+1)-(1/4)*ln(b^2+9)+(2*I)*arctan(2*I+b)+arctan(2*I+b)*b+I*Pi*(1/2))+
   piecewise(And(0 < b, a < 0), -(2*I)*Pi, 0), b = a, 0, b < a, piecewise(b < 0, -I*arctan(4*b/
   (b^2-3))*(1/2)-(1/4)*ln(b^2+1)-(1/4)*ln(b^2+9)+(2*I)*arctan(2*I+b)+arctan(2*I+b)*b-I*Pi*(1/2),
   b = 0, I*Pi-3*ln(3)*(1/2), 0 < b, -I*arctan(4*b/(b^2-3))*(1/2)-(1/4)*ln(b^2+1)-(1/4)*ln(b^2+9)+
   (2*I)*arctan(2*I+b)+arctan(2*I+b)*b+I*Pi*(1/2))+piecewise(a < 0, I*arctan(4*a/(a^2-3))*(1/2)+
   (1/4)*ln(a^2+1)+(1/4)*ln(a^2+9)-(2*I)*arctan(2*I+a)-arctan(2*I+a)*a+I*Pi*(1/2), a = 0,
   I*Pi+3*ln(3)*(1/2), 0 < a, I*arctan(4*a/(a^2-3))*(1/2)+(1/4)*ln(a^2+1)+(1/4)*ln(a^2+9)-(2*I)*
   arctan(2*I+a)-arctan(2*I+a)*a-I*Pi*(1/2))-piecewise(And(0 < a, b < 0), -(2*I)*Pi, 0))

The first one probably has the correct answer inside, but it has conditions like ln(a)<ln(b), so that case never gets selected when the values are complex.

I was told that the following workout was done in Maple.  I have tried to read material about how to do it but I am completely lost.  Can someone indicate me where I can read in oder to do what the image says or give me some tips please?  

where all functions are dependent on the variables (u,v).

Observation: subscripts means partial derivatives of the function while superscripts are just for naming different functions,i.e Gamma^1 and Gamma^2 are two functions.

 

Sergio

 

Sergio

 

f := (z, t) -> ln(t)^2/((t^2+1)*(t-z));

int(f(z, t), t = 0 .. infinity) assuming Im(z) > 0;
       int(ln(t)^2/((t^2+1)*(t-z)), t = 0 .. infinity)

int(f(a + I*b, t), t = 0 .. infinity) assuming a::real, b > 0; # 0*infinity
       -sqrt(a^2+b^2-2*b+1)*signum(I*arctan(b, a)-I*arctan(-b, -a)-I*Pi)*
       infinity/((I*b-I+a)*(I*b+I+a))

int(f(z, t), t = 0 .. infinity) assuming Re(z) > 0, Im(z) > 0;
       int(ln(t)^2/((t^2+1)*(t-z)), t = 0 .. infinity)

int(f(a + I*b, t), t = 0 .. infinity) assuming a > 0, b > 0;
      -((3*I)*Pi^3*b+3*Pi^3*a-(16*I)*Pi^2*arctan(b/a)-(6*I)*Pi*ln(a^2+b^2)^2+(24*I)*
      Pi*arctan(b/a)^2+(6*I)*ln(a^2+b^2)^2*arctan(b/a)-(8*I)*arctan(b/a)^3-8*Pi^2*
      ln(a^2+b^2)+24*Pi*ln(a^2+b^2)*arctan(b/a)+ln(a^2+b^2)^3-12*ln(a^2+b^2)*
      arctan(b/a)^2)/(24*(-b^2+(2*I)*a*b+a^2+1))

So it looks like the first three can be made to work as well (and the result in terms of z will be much neater).

 

I have noticed that I don't receive e-mails anymore when contributions are submitted to my subscriptions.
I used to.
Has this happened to anyone else?

It is embarrasing to have asked somebody a question and gotten a reply you are not made aware of.

What to do about it?
 

Hello every body

I have a plot that contains two curve. I need to chracterize the curves with `min(D_{T})` and `max(D_{E})`. Is it possible to write legend of plot such that when include it in latex file,  T and E be presented in indices?

"The account type or email address or password is incorrect."

None of those things is true. Using those same credentials, I am able to log in to Maple Cloud in my office but not from home. 

Has anyone else had this problem or know of a solution?

Thanks!

Running Maple 2017 in office on Windows 7 and at home on Windows 10.

Office copy is through a site license purchased by my university. Home copy is a personal home-use copy obtained through the Maple Adoption program.

I am attempting to build a text field at the bottom of this worksheet MathApps-ResistorsMark.mw  that asks users for the resistance.

I am hoping to have the value of the text field evaluated using the Module() at the bottom of the startup code, for use as a question within MapleTA.  For some reason I can get the code to work for a slider, but not a textbox.

I have limited knowledge about startup code.

Notice: I will be removing the resistance from the diagram for students after I know it works.

I appreciate any help that can be offered.

Dear Maple users,

I am solving a system of linear equations Ax=b where A is a matrix (243*241) which contains a rational polynomial of unknown "kappa" along with floating numbers. As suggested in some other posts I am using Linear algebra package with the LinearSolve command and option "solve" to find out unknown vector x. b is a vector having entries zero and 1. The system is such that two equations are redundant but it is difficult to recognise which two are redundant and hence for the time being I am keeping them in the matrix. (For a known value of kappa (say kappa=2) I have checked that two equations are redundant.) For the reference, the matrix and the right-hand vector b is attached as text.

There are two issues

1) Maple takes very long time (12 hours and so) to get x=b\A;

2) The result is a long expression i.e.  x[i] is a rational polynomial in kappa; a very long rational polynomial which I am importing as a text. I am not sure if maple exports all terms in the polynomial as for the different value of kappa I see Ax-b >0. 

How can I overcome this problem? Any help will be greatly appreciated. 

 

 

as screen shot shown i just was wondering if the mechanic is available my engine dispatched again so um i guess i can pay in reputation points or food stamps, i just dont see why engine would desire either tho being an artificial entity and all. i mean its not like you need to eat.

ode1a := diff(y1(tt),tt) = round(rhs(odeparm1[1][1]))*y1(tt) + round(rhs(odeparm1[1][2]))*y2(tt) + round(rhs(odeparm1[1][3]))*y3(tt);
ode2a := diff(y2(tt),tt) = round(rhs(odeparm1[1][4]))*y1(tt) + round(rhs(odeparm1[1][5]))*y2(tt) + round(rhs(odeparm1[1][6]))*y3(tt);
ode3a := diff(y3(tt),tt) = round(rhs(odeparm1[1][7]))*y1(tt) + round(rhs(odeparm1[1][8]))*y2(tt) + round(rhs(odeparm1[1][9]))*y3(tt);
sys := subs(y3(tt)=1,[ode1a,ode2a]);
print(DEplot(sys, [y1(tt), y2(tt)], tt = 0 .. 16, y1 = -16 .. 16, y2 = -16 .. 16, color = magnitude, title = `Stable Limit Cycles`, arrows = curve, dirfield = 800, axes = none));

 

how to mirror the vector field graph mathematically?

mirror the graph about x=0 this line,

so that the graph looked flip

i find curl can do, but how to do ?

 

restart;
with(VectorCalculus):
SetCoordinates('cartesian'[x(t), y(t), z(t)]);
Curl((x(t),y(t),z(t)),(Diff(x(t),t) - a11*x(t) - a12*y(t) - a13*z(t),Diff(x(t),t) - a21*x(t) - a22*y(t) - a23*z(t),Diff(x(t),t) - a31*x(t) - a32*y(t) - a33*z(t)));
Error, (in VectorCalculus:-SetCoordinates) coordinate system `cartesian[x(t), y(t), z(t)]` does not exist
Error, (in Vector) dimension parameter is required for this form of initializer

 

Hi quick question.  When I am writing in maple 2D input the next line seems to add a space and I have to manually go and take the spaces out.  Is there a quick fix for this?  

Thank you.

Hello everybody

I'm using discrete distributions from the Statistics package and I found a rather strange result.

In short the theoritical values of some statistics of a NegativeBinomial(1, P) Random Variable (P being the probability of success equal to 1e-4) are correctly computed, but their empirical estimators computed from a sample of this RV are roughly wrong.

For NegativeBinomial(1, P) is similar to Geometric(P) I asked Maple to compute the theoritical values of some statistics of Geometric(P) and next to assess their empirical values from a sample of Geometric(P).
Some discrepancies still remain but they can be explained by statistical fluctuations.

Could you please look to the attached file (an error on my part is still possible) and help me to fix this ?

Thanks in advance


PS : the histogram of Sample(NegativeBinomial(K, P), AnySizeYouWant) is obviously wrong (it should look like a decreasing exponential) 


 

Download NegativeBinomial.mw

I have recently reinstalled the MapleSim 6.4 but the probe windows do not appeaar anymore.

The image below shows that there are 3 probes (none are disabled) and when I run the simulation nothing happens.,

seq(alias(a[i] = RootOf(_Z1^6-3*_Z1^2-2*_Z1+11, index = i)), i = 1..6):

ee := a[1]*a[5]+a[2]*a[6]+a[3]*a[4];

evalf(ee);
                       3.999999999 + 0. I

evala(ee);
  -(18/449)*a[1]^2-(196/449)*a[1]^3-(128/449)*a[1]^4+(40/449)*a[1]^5+(110/449)*a[2]^2-
  (324/449)*a[2]^3-(220/449)*a[3]-(680/449)*a[2]-(320/449)*a[1]-(60/449)*a[3]*a[2]^2*a[1]^2+
  (64/449)*a[3]*a[2]*a[1]^2+(128/449)*a[3]*a[2]^2*a[1]-(256/449)*a[3]*a[2]*a[1]-
  (32/449)*a[2]^3*a[3]*a[1]^3-(16/449)*a[3]*a[2]^2*a[1]^5-(16/449)*a[3]*a[2]^3*a[1]^4+
  (32/449)*a[3]*a[2]*a[1]^5-(16/449)*a[3]*a[2]^2*a[1]^4-(24/449)*a[3]*a[2]*a[1]^4-
  (56/449)*a[3]*a[2]^2*a[1]^3-(16/449)*a[3]*a[2]^3*a[1]^2+(40/449)*a[2]^2*a[1]^2+
  (66/449)*a[3]*a[2]^2-(232/449)*a[3]*a[2]+(24/449)*a[3]*a[1]^5+(64/449)*a[3]*a[1]^4+
  (164/449)*a[3]*a[1]^3+(130/449)*a[3]*a[1]^2-(192/449)*a[3]*a[1]+(228/449)*a[2]^3*a[3]-
  (32/449)*a[2]*a[1]^5+(88/449)*a[2]*a[1]^4+(128/449)*a[2]*a[1]^3+(256/449)*a[2]*a[1]-
  (32/449)*a[2]^3*a[1]^5-(48/449)*a[2]^3*a[1]^3-(88/449)*a[2]^3*a[1]^2+(256/449)*a[2]^3*a[1]-
  (256/449)*a[2]^2*a[1]+(32/449)*a[2]^2*a[1]^5-(48/449)*a[2]^2*a[1]^4-(48/449)*a[2]^2*a[1]^3+1780/449

evalf(evala(ee));
                  3.139680582 - 1.737673929 I

I wasn't able to figure out what it depends on, but evala(ee) doesn't always do the same thing. If I don't evaluate evalf(ee) first, then most times I get the correct result evala(ee)=4.

This is in Maple 2017.2, system="X86 64 WINDOWS", wordsize=64.

 

aa := tan(Pi/11)^2;
bb := RootOf(_Z^5-55*_Z^4+330*_Z^3-462*_Z^2+165*_Z-11, index = 1); # bb = aa
ee := (exp(-Pi-I*Pi*aa/bb))^(1+I);

seq((proc() try timelimit(k, signum(Re(ee)-1/k)) catch: lprint(lastexception) end try end proc)(),
    k = 1..10);

`shake/shake`, "time expired"
`expand/sin`, "time expired"
`evalr/tan`, "time expired"
sdmp:-mul, "time expired"
                        1, 1, 1, 1, 1, 1

An explanation: aa/bb=1, so, as we know from here, ee=exp(-2*Pi), and ee is tricky to evaluate numerically. Normally signum(Re(ee)-1/5) just seems to hang indefinitely, which is not the worst thing it could do. But after one of the timelimit interrupts (or after clicking "Interrupt the current operation"), something breaks, and Maple starts returning wrong values.

This is in Maple 2017.2, system="X86 64 WINDOWS", wordsize=64.

Also, is there any way to clear the cached values so that this computation can be repeated without doing restart?

 

1 2 3 4 5 6 7 Last Page 1 of 209